Unable to install plugin in netbeans.

No replies
Offline
Joined: 09/29/2013

 Hello i downloaded Env3d plugin for netbeans and when i try to http://plugins.netbeans.org/plugin/39802/env3dmodule 

When i browse for the plugin and try to install it using netbeans i get the below error 

       Some plugins require plugin Common Annotations to be installed.

The plugin Common Annotations is requested in version >= 1.17.1 but only 1.14.1 was found.

The following plugin is affected:
      Env3DModule

Some plugins require plugin Editor Library to be installed.

The plugin Editor Library is requested in version >= 2.1 (release version 2) but only 3.24.1.19.31 (of release version different from 2) was found.

The following plugins are affected:
      Generic Languages Framework - Refactorings
      Spellchecker Java Language Bindings

 

Can you please let me know what is the mistake i am doing here.

 

Thank you :)